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Here’s another handful of ARRIS odds and ends that I've accumulated since my previous
newsletter that you might find useful. Some might be old and forgotten, but some are fairly new
and unique to the current release of ARRIS. Hopefully there’s at least one or two you didn’t know.

Layer Menu Trivia

Although the Layer menu is arguably the most commonly used ARRIS menu in any ARRIS
session, I'm often surprised (appalled?) at the number of buttons from this menu that have never
been explored by many users. To benefit the members of that select group, | have a compiled a
brief summary of several of the more overlooked layer functions. So if you haven't tried all of
these, would it kill you to press a few new buttons now and then?

o Coloring Layers By Their Mode Settings

Below each of the E, S, & D columns on the Layer menu are three buttons labeled DB. If you
select the DB button below the S column, you will notice that the Default Color For
Searchable Layers menu will pop up along with a prompt asking you if you want to Override
display color for mode SD layers?

What does this mean? It means if you select a color from the menu, say color 29, then all the
entities on all the layers which are turned on for Display and Search (but not Edit) will be
temporarily displayed as gray (or color 29 ) after you select the Exit & Display button.

Why do this, you ask? Well, suppose you were working on a roof framing plan and you
wanted to have the layer that contains the first floor walls displayed in some neutral color as a
background. Just turn the wall layer on for Display and Search and follow the steps outlined
above and it will suddenly be displayed as gray...along with any other layers that have only
Display and Search turned On. If you need more layers to be highlighted, turn them On for
Display only and select a new color to represent these layers by selecting the DB button
below the D column. When you are ready to turn this feature off, simply right-click on any of
the three DB or Color Number buttons (referenced in the first paragraph) and t he colors will
all be returned to their original database colors. See, wasn’t that painless?

o Load

Although you might think the meaning of the Load function would be kind of obvious, | have
encountered lots of users who have never pressed this button. Too bad, it's an incredibly
powerful option that can be used to link layers to your current drawing or viewport without
having to access the dreaded Drawing Layer Manager menu or redefine the viewport.

The layer Load button is similar in function to AutoC AD’s X-Ref feature. It lets you load (or
link to) another layer into your current drawing or viewport. This loaded layer can come from
your current database or from any other database in your project directory. However unlike a
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copied layer that is detached from the original, this layer is really a link to its source. If you
make a change from the linked database, the change is also reflected at the source.

Put simply, any changes made to a loaded layer are reflected in every location where that
layer is referenced. For this reason, the Load option lets you specify the permissions of the
layer being loaded as RO, RW or TMP so that the layer can easily be protected from
accidental modifications if it is only needed as a background. By the way, if a lay eris
assigned a TMP status, it will only be a temporary member of the drawing or viewport into
which it was loaded. When you exit the drawing, a TMP layer will no longer reappear as a
member of that drawing or viewport (hence the word TMP, got it?).

External Database

If you would like to see a list of all the layers that are linked to (see above) a database other
than the current database, select the External Database button. The source database(s) will
be listed on the right side of the Layer menu where the layer modes are typically displayed. If
this menu section is blank, there are no layers loaded from an external database.

Remove

It is a common misconception that this button will delete a layer from the current drawing or
viewport. In reality, the Remove button only removes the specified layer(s) from the current
drawing or viewport layer list. This is very useful if you’ve loaded a number of extraneous
layers using the Load option (see above) and now you’d prefer they go away. Remember, the
only way to permanently delete databases, drawings, sheets or layers is to select the Delete
option (big red X) from the File menu and follow the prompts.

#Prompt#

When creating new layers, many users have never used the #PROMPT# option in the
Number, Name and/or Description fields. By setting the Number, Name and Description
values to #PROMPT# (an option from the prompt line), then selecting OK from the Layer
menu, you can quickly enter a long list of new layer names and descriptions sequentially from
the prompt line without having to manually reselect those boxes from the menu each time.

R/O Update

For users working in a multi-user environment, the Read Only Update button can be used to
instantly update all the read only layers in your current drawing or viewp ort without having to
reload it from disk. This can be used to view any modifications that were made by your fellow
users working simultaneously on those same read only layers in the background. It also
saves you from having to yell across the office to se e if any updates were made in the third
cubicle over from yours (warning: for some reason other users tend to frown on this).

Did You Know?

a

Almost everybody has discovered that you can use the zflat command to quickly flatten
elements with 3D coordinates (such as topo maps) into 2D coordinates with a Z value of 0.
But did you know that you could also use the zflat command to quickly generate
foreshortened elements in your exterior elevations?
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Lets say you have angled bay window on your floor plan that you need to draw a front
elevation of but you dread having to project all those angled window mullions down to
represent the window(s) at a 45 angle. Instead, just draw the window (or place a window RI)
on the flat X,Y plane. Using Move/Scl Rot, rotate the window about the Y -axis to represent
the angle of your bay window (example: rotation = 0,45,0). ( Note: If you used an RI to
represent your window, freeze the RI before continuing on to the next step).

Now type the zflat command, fence-in your rotated window element and accept the default
value of 0. Voila! Your window has been “flattened” to the XY plane and can now be easily
moved or copied to it's proper new location. (Thanks to Keith Kirsch for this handy time
saver).

This may be a familiar behavior to many ARRIS users, but did you know that the two -point
distance command when applied to opposite corners of a box displays the distance
measurement of both sides of the box as well as the distance between the corners? The
vertical and horizontal leg distance s are show as the Delta X and Delta Delta Y values
respectively. You can also use this trick to measure the thickness of a window frame in the X
and Y directions by getting the distance between any two inside and outside corner points.

Did you know that in ARRIS 8, the Layer Retain option was added to the Match Entity menu
to facilitate copying without having to go all the way up to the desktop Copy menu? Well |
didn’t until very recently — d’oh!

Did you know a right-click on the Trim or Extend Line button will shortcut you to the tool which
allows you to trim or extend a line or circle using distance instead?

Did you know there was a Search Method option on the Edit menu called Select Single Entity
From Inside Of Fence? It can be used to cycle through multi ple entities that share the same
data point, such as RI’s, so you can select only the one you wish to edit. How long has this
option been on the Edit menu? Well, at least since ARRIS 2001 I’'m embarrassed to report.

Have you ever drawn a box and wanted to draw another offset box 2’ larger without having to
use New Ref with coordinates or (4) offset lines which have to be joined at the ends? There is
a great Offset Lines/Curves button under the Line Tools menu that will do the job faster. The
Offset button (see icon below) has 3 prompts.

e

Offset Line/Circle Button

1) Offset distance? positive value offsets to right, negative to left. Enter [2] for a 2-foot
offset.

2) 1 bndry pt (F4:chase, F:10 new offset): [Select the right vertical line near the bottom
corner using your F4 key]

3) Select end point (F10 for auto-chase): [Press F10 key]. A new box 2’ larger than the old
box should appear. If the new box was drawn 2’ smaller (inside) the existing box, your
cursor wasn'’t close enough to the lower h alf of the line. Just select Undo and try it again.
With a little practice, you can get it right first time. Also try experimenting using [-2] for a
box that is 2’ smaller than the existing box. ( Note: this command will offset any
combination of contiguo us lines, circles or lines and circles (closed or open) not just
boxes!

If you've never used the Display Wall Points button to highlight the reference lines and
intersections of smart walls you’re missing out on a great troubleshooting and training
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|j
Display Wall Points Button

tool (see icon above). This button is located in the Wall Tools menu along with many other
useful smart wall tools. | use this button so often that I've added it my TOOLBAR menu.
However, | got tired of responding to the Selection Method prompt with all, so | modified the
TOOLBAR command to :mn_wipts;all so that the all response was automatic.

Did you know there’s a powerful new feature under the ARRIS 8.x Copy menu called Copy to
Clipboard and Paste from Clipboard? If you haven’t tried using it yet, you're missing out on a
really powerful feature. Be sure and pay attention to the Layer Retain status, it will determine
upon which layers the copied and pasted entities are eventually placed. ( Note: You can even
use Ctrl V to paste the copied entities from the clipboard!).

Software Buzz

ARRIS 8.1 is now shipping!

If you haven’t upgraded to ARRIS 8.1, visit www.sigmaserv.com/ArrisNews.html and check
out the ARRIS 8.1 New Features PDF file or contact me for details.

New seats of ARRIS 8.1 can now be purchased for the unbelievably low price of $995! In
addition to receiving the entire ARRIS Architect Studio, this price also includes a free 1 -year
ARRIS Maintenance Subscription and free 1-year eZ Subscription.

Sigma Design and @ Last Software have joined forces to create one of the most compelling
CAD/Design offerings available today. For the low price of $1295, ARRIS customers receive
the complete ARRIS 8.1 Architect Studio and a complete, full version of the award winning
3D design software, SketchUp. This bundle also includes all of the additional items
mentioned above and is available for purchase immediately. For more information on the
powerful SketchUp software, visit www.sketchup.com. ARRIS 8.1 users can also purchase a
copy of SketchUp directly from Sigma Design through the end of April for $329.

Stay tuned for the upcoming release of the 7.3 Translator from Expert Infocad. It is a great
new release that will provide support for ARRIS 8.1 and AutoCAD 2004. It was rewritten from
scratch in C++ to be able to support more advanced AutoCAD features. For the first time, it
will be translating SOL/D3D entities (ACIS format) and Spline entities (NURBS curves) from
AutoCAD to ARRIS. New seats are priced at $275, upgrades from ARRIS 8.0 at $150 and
upgrades from 2001 at $175. Versions older than 2001 need to purchase a new seat.

A new version of Jeff Small’'s ARRIS++ has been issued to correspond to the ARRIS 8.1
release. This works with ARRIS spin #101 and #103. You can read about all of the new
features at: http://cisa.home.comcast.net/aplus/APLUS/ap chg08.html

Well fellow users, | hope you found this issue of For What It’s Worth to be informative. Stay
tuned for the next issue where I'll review some of the new 8.1 features.

Until then, if you have any questions about ARRIS or eZ software, the Expert Translator, training,
data conversion services, technical support, evaluation software, ARRIS updates, 3 " party
applications, web site creation, colored rend erings or freelance drafting services, please don’t
hesitate to contact the number or email address listed below...operators are standing by!
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